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Refer to Licensing for more information on how Архива's licensing works.

Behaviour

The following behaviour is observed when a license is invalid:

  • Архива v2 - all emails will be archived to the no archive queue (thus they will not be visible in the search results). Only when the license issue is resolved, will the files be archived.
  • Архива v3 - the product will revert to Free Edition mode.  Archiving will occur normally although certain features of the product will be disabled.

Diagnosis

When a license is invalid, a reason will usually be given. To establish the reason, click Configuration->About. Below the invalid license, it should provide a clue as to why it is invalid. If not, click Status-Alerts. An alert should be outputted with the exact reason why the license is invalid.

If that does not help, be advised the server performs license checks soon after it is started. When the server has completed the license checks, the reason why the license is determined to be invalid will be outputted in the debug log file. Thus to proceed, delete the debug.log file in Configuration->Logs, set the log level to Troubleshoot, restart the server. After the server has started, examine the trace information outputted in the debug.log file. A detailed reason why the license check fails will be outputted in the log.

License Expired

Invalid License Reason: expired license

If using the , an expired license means that the license is a temporary license. It has a time restriction on it.

Resolution: Contact Архива sales to obtain a permanent license.

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ISP Edition Users: If the ISP Edition software is configured correctly, licenses pertaining to instances under management should never expire assuming all outstanding invoices are paid. This is due to the fact that the ISP Edition product will automatically license all the instances it manages. If the licenses are expiring, it can mean that the ISP Edition software is unable to sync with its instances. Please refer to Sync Failure for more information.

No Mailboxes Exceeded

Invalid License Reason: No mailboxes exceeded

If the number of mailboxes on an license is exceeded, the license will become invalid.

To determine which licenses are being used by the system, check the license counts outputted in a file called license.cnt or mailboxes.cnt accessible from Configuration->Logs.

Resolution: 

a) Delete All Bogus Mailboxes

 If confident that the actual no of mailboxes should be within the purchased limit:

  1. Examine the license.cnt file (location revealed above) to see which mailboxes are included in the license count
  2. Perform a search for each bogus mailbox in the Архива search interface
  3. Delete all emails associated with the bogus mailboxes

For example, to search for a mailbox, enter anyaddress:"printer101" in the search box. This should display all emails with the name "printer101". Thereafter, select all emails returned from the search results by click Select All, then click Delete to proceed with the deletion. It is possible define an archive rule in Configuration->Archive, to ensure that no emails from printer101 are archived.

It may take up to 24 hours before Архива's licensing engine will recognize that mailboxes have been removed. To speed up the process, restart the Архива server.

 

b) No More Mailboxes 

The license may have run out of mailboxes. It is necessary to extend the license by purchasing additional mailboxes. Do this by logging in the Архива website, click Licenses, select the License, type the number of mailboxes needed (in total - inclusive of old mailboxes) and click the Extend button. Complete the purchase process.

Search Index Corrupted

Invalid License Reason: exception occurred while conducting license check. Volume index corrupted.

Oddly enough, a corrupted search index may lead to an invalid license. The reason is that to determine whether a license is valid or not, Архива searches the index to check the mailbox counts. 

Resolution: Identify the volume with the corrupted search index. Stop the server and delete the contents of the volume index directory (not the store directory!). Thereafter, start the server. In Configuration->Volumes, reindex the volume.

Out Of Memory 

Invalid License Reason: exception occurred while conducting license check. GCC overhead exceeded or Out Of Memory.

When the server deteremines whether a license is valid or not, it performs a search across all volumes to perform mailbox counts. If your volumes are large and there is little free RAM available to the server, the server may run out of memory. In this case, the license check will fail. 

Resolution: Increase the amount of RAM available to Архива. Refer to OutOfMemory.

License Signature Invalid

Invalid License Reason: Signature check failed. 

If the license file itself has been modified in any way, the signature check will fail and the license will become invalid. A license signature will also fail if the wrong license file is being used for the wrong product. For example, if Архива v2 license is installed in a Архива v3 product.

Resolution: Obtain the correct license file for the product you are using. 

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